豆播客

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
查看: 199|回复: 0

易语言写游戏辅助

[复制链接]

12

主题

12

帖子

104

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
104
发表于 2021-2-21 17:33:27 | 显示全部楼层 |阅读模式
1.制作程序供练手

首先在易语言写一个简单的点击按钮数值增加的程序
QQ截图20210221172007.png
这样我们每点一次按钮就a就会+1

2.使用CE查找基址

打开我们写的软件,再打开CE,在当前进程中选择我们的程序打开
QQ截图20210221172404.png
因为a是整数型并且a是0,我们在数值中输入0后点击首次扫描
QQ截图20210221172520.png
扫描完成后会有较多数值,我们点击软件中的按钮,然后在ce中把0改为1再次搜索(因为我们每点一次按钮a就会加一)
经过多次搜索后便找到了基址(绿色的),因为程序较为简单,所以没有偏移,如果是复杂的则需要找偏移基址
QQ截图20210221172715.png
3.编写简易代码
我们打开易语言,写如下代码(注意!需要使用到 超级模块
QQ截图20210221173120.png QQ截图20210221172932.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 窗口程序集_启动窗口
  4. .程序集变量 程序名, 整数型
  5. .程序集变量 数值, 整数型

  6. .子程序 _按钮1_被单击

  7. 数值= 读内存整数型 (程序名, 十六到十 (“004A2650”))
  8. 调试输出 (数值)
  9. 调试输出 (写内存整数型 (程序名, 十六到十 (“004A2650”), 100))

  10. .子程序 __启动窗口_创建完毕

  11. 程序名 = 取进程ID (“a.exe”)
  12. 调试输出 (程序名)
复制代码
运行后点击按钮从CE中就可以看到数值已经变为了100,这就代表我们已经成功修改了数值
QQ截图20210221173120.png
4.结尾

好的,现在你已经学会了如果编写辅助,下面就用CE修改 赛博朋克2077 中金钱的数值吧!

签名请不要带有违规信息
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|BeanBBS

GMT+8, 2021-4-20 23:36 , Processed in 0.043369 second(s), 20 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表